Полезное‎ > ‎Статьи‎ > ‎

Cisco router первичная настройка

Router>
Переходим в превелегированный режим командой enable
Router>enable
Router#
удаляем имеющуюся конфигурацию, находящуюся во флэш-памяти, и перезагружаем маршрутизатор:
Router#erase startup-config
Router#reload
Ждем пока роутер перезагрузится, наблюдая за процессом загрузки в окне консоли, после чего снова переходим в превилигированный режим
Router>enable

Переходим в конфигурационный режим и даем команду hostname:
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname Gw0
Gw0(config)#
Включим режим хранения паролей в файле конфигурации устройства в зашифрованном виде:
Gw0(config)#service password-encryption
Отключим управление маршрутизатором через http и https и CDP
Gw0(config)#no ip http server
Gw0(config)#no ip http secure-server
Gw0(config)#no cdp run
Зададим пароли на подключения через консольный порт
Gw0(config)#line con 0
Gw0(config-line)#password пароль
Gw0(config-line)#login
Gw0(config-line)#exit
И Telnet
Gw0(config)#line vty ? О, сколько он там сказал доступно? 0-1441 значит line vty 0 1441 ))
Gw0(config-line)#password пароль
Gw0(config-line)#login
Gw0(config-line)#exit
Зададим пароль на Enable режим
Gw0(config) enable secret пароль_enable_режима

Перейдем к настройке интерфейса внутренней сети. Если маршрутизатор имеет гигабитные порты то названия портов можно сократить как Gi 0/0 (Gigabit ethernet) , если 100 Мбитные то скорее всего это будут Fa (fast ethernet)
В принципе, если вы сомневаетесь в команде, нажмите TAB — в командной строке команда дописалась? значит норма, не помните что вводить? введите знак вопроса… IOS выдаст вам все доступные команды в данном контексте.
Gw0(config) #interface Gi 0/0
Gw0(config-if)#ip address 192.168.0.1 255.255.255.0
Gw0(config-if)#description LAN
Gw0(config-if)#no shutdown
Gw0(config-if)#exit
Задаем dns-сервера

Gw0(config)# ip name-server 192.168.0.2

Все, маршрутизатор доступен телнетом по 192.168.0.1
Записываем конфигурацию в память командой
Gw0# copy running-config startup config или командой wr


Переходим в превелегированный режим
Gw0>enable
Устанавливаем точное время для генерации ключа
Gw0#clock set 20:10:00 23 May 2012
Переходим в конфигурационный режим
Gw0#configure terminal
Указываем имя домена (необходимо для генерации ключа)
Gw0# ip domain name iamroot.ru
Генерируем RSA ключ
Gw0(config)# crypto key generate rsa
Заводим пользователя user
Gw0(config)# username user privilege 15 secret пароль
Активируем протокол ААА ( про данный протокол я расскажу позже более подробно )
Gw0(config)# aaa new-model
Входим в режим конфигурирования терминальных сессий ( про число 1441 я рассказал в первой части )
Gw0(config)#line vty 0 1441
средой доступа через сеть по умолчанию у нас будет SSH
Gw0(config-line)# transport input ssh
Наверное вы обратили внимание что некоторые события пишутся в консоль что не очень удобно при наборе команды именно поэтому включаем автоматическое поднятие строки
Gw0(config-line)# logging synchronous
время таймаута до автоматического закрытия SSH сессии в 30 минут
Gw0(config-line)#exec-timeout 30 0
Выходим из режима конфигурирования нажатием Ctrl+Z
сохраняемся.
Gw0# wr

Следующая команда копирует текущую рабочую конфигурацию IOS Cisco в конфигурацию запуска:
Gw0#copy running-config startup-config
Оно же
Gw0#copy run start
Оно же
Gw0#wr

чтобы сохранить рабочую конфигурацию на сетевом сервере при помощи протокола TFTP:
Gw0#copy run tftp://192.168.0.100
Address or name of remote host [192.168.0.100]? [enter]
Destination filename [router-confg]? [enter]

Чтобы сохранить конфигурацию на CF карте
Gw0#copy run flash:

Чтобы вернуть из бекапа соответственно меняем местами источник и место назначения
Например
Gw0#copy flash: run

И не забываем любимую комманду
Gw0# wr


Gw0(config) #interface Gi 0/1
Gw0(config-if)#ip address 89.80.80.80 255.255.255.248
Gw0(config-if)#description WAN
Gw0(config-if)#no shutdown
Gw0(config-if)#exit
Gw0(config)#ip forward-protocol nd
Gw0(config)#ip route 0.0.0.0 0.0.0.0 89.80.80.80

Включаем скоростную передачу от Cisco для IPv4
Gw0(config)#ip cef
отключаем для IPv6
Gw0(config)#no ipv6 cef
Настраиваем NAT
на WAN интерфейсе
Gw0(config)#interface Gi0/1
Gw0(config-if)#ip nat outside
на локальном интерфейсе
Gw0(config)#interface Gi0/2
Gw0(config-if)#ip nat inside
создаем список IP имеющих доступ к NAT
Gw0(config)#ip access-list extended NAT
Gw0(config-ext-nacl)#permit ip 192.168.0.0 0.0.0.255 any
включаем NAT на внешнем интерфейсе
Gw0(config)#ip nat inside source list NAT interface Gi0/1 overload

Gw0#conf t
Gw0#(dhcp-config)#ip dhcp pool LAN
Gw0#(dhcp-config)#network 192.168.0.0 255.255.255.0
Gw0#(dhcp-config)#dns-server 192.168.0.1
Gw0#(dhcp-config)#default-router 192.168.0.1
время жизни выданного адреса в днях
Gw0#(dhcp-config)#lease 7
Gw0#(dhcp-config)#exit

указывается диапазон, из которого выдавать адреса нельзя
Gw0(config)#ip dhcp excluded-address 192.168.0.1 192.168.0.100
Gw0(config)#ip dhcp excluded-address 192.168.0.200 192.168.0.254

конфигурирование DHCP завершено, переходим к настройке кэширующего DNS сервера

Доменное имя компании
Gw0(config)#ip domain name iamroot.ru
DNS адреса провайдера
Gw0(config)#ip name-server xxx.xxx.xxx.xxx
Gw0(config)#ip name-server yyy.yyy.yyy.yyy
Включаем трансляцию имен в адреса
Gw0(config)#ip domain-lookup
включаем DNS сервер
Gw0(config)#ip dns server
Gw0(config)#exit

Gw0#write


Собственно мы можем использовать конвейеры при  выводе команд ( допустим  show )

Допустим выведем только те строки где встречается PPP

vpn#show processes cpu | include PPP
 138           0           3          0  0.00%  0.00%  0.00%   0 PPP SIP
 139           0           5          0  0.00%  0.00%  0.00%   0 PPP Bind
 140           4          10        400  0.00%  0.00%  0.00%   0 PPP IP Route
 189           0           2          0  0.00%  0.00%  0.00%   0 PPP Compress Inp
 190           0           2          0  0.00%  0.00%  0.00%   0 PPP Compress Res
 207           0           2          0  0.00%  0.00%  0.00%   0 PPP NBF
 376       11940     4395282          2  0.07%  0.07%  0.07%   0 PPP manager
 377        8332     4395327          1  0.07%  0.04%  0.05%   0 PPP Events
 378         204      141170          1  0.00%  0.00%  0.00%   0 Multilink PPP

Либо исключаем используя exclude

Вывести конфигурацию начиная со слова router можно командой sh run | begin router

Отобразить какой-либо определенный раздел конфигурации sh run | section router eigrp

Отобразить строки в которых встречаются слова «Administrative Mode» или «Fa»: sh interface switchport | i Administrative Mode|Fa

Перенаправление вывода команды на TFTP-сервер и вывод команды в консоли:

vpn# sh ip int br | tee tftp://192.168.0.1/bri.txt

Добавление вывода команды к уже существующему файлу:

vpn# sh ip int br | append tftp://192.168.0.1/bri.txt

Чуточку дебага NAT и DHCP

router# sh ip nat translations
router# sh ip nat statistics
router# debug ip nat

router# show ip dhcp binding
router# show ip dhcp conflict
router# show ip dhcp server statistics
router# clear ip dhcp binding [ip-address]



Настройка Cisco Configuration Professional

Router(config)# line vty 0 4
Router(config-line)# privilege level 15
Router(config-line)# login local
Router(config-line)# transport input telnet
Router(config-line)# transport input telnet ssh
Router(config-line)# exit
Router(config)# ip http server
Router(config)# ip http secure-server
Router(config)# ip http authentication local
Router(config)# username <username> privilege 15 password 0 <password>